iChunUtil

iChunUtil

 

This mod is a shared library required by a couple of iChun’s Mods. Made for Minecraft 1.5 or later.

A majority of my mods will require this mod as a base.

Installation: Drop it in the /mods/ folder. Requires Minecraft Forge installed.

Version 4.0.0 For MC 1.7.10: Download

Version 3.3.0 For MC 1.7.2: Download

Version 3.2.1 For MC 1.7.2: Download

Version 3.2.0 For MC 1.7.2: Download

Version 3.1.0 For MC 1.7.2: Download

Version 3.0.0 For MC 1.7.2: Download

Version 2.4.0 For MC 1.6.X: Download

Version 2.3.0 For MC 1.6.X: Download

Version 2.2.0 For MC 1.6.X: Download

Version 2.1.0 For MC 1.6.X: Download

Version 2.0.0 For MC 1.6.X: Download

Version 1.0.1 For MC 1.5.X: Download | Mirror

Version 1.0.0 For MC 1.5.X: Download | Mirror

322 Comments

  1. Kyle Brookes March 18, 2013 3:48 pm  Reply

    I Cant Download iChun Util Because repo/CreeperHost Is Down So please Fix it

    • jscooly555 March 18, 2013 8:59 pm  Reply

      Use the mirror!

      • asdf April 10, 2013 4:26 am  Reply

        no
        no
        nio

          • The Parking Meter July 4, 2013 10:43 pm 

            Hello!

          • 1x1x1x1 July 18, 2013 5:21 pm 

            Hello Yogscast and Lt. Sparklez.

        • Ant September 6, 2014 4:13 pm  Reply

          no
          no nio
          no nio
          no nio
          no nio
          no nio
          Ichun blog cant

      • sean January 3, 2014 6:14 am  Reply

        1.6.2 no Mirror :(

        • Original The Character February 24, 2014 2:09 am  Reply

          YOU FAKER! I’M THE TRUE ONE!

          • Original May 28, 2014 12:04 am 

            NO, YOU FAKER! I’M THE TRUE ONE!

          • Liam02468 August 4, 2014 9:41 am 

            NOT TRUE!!!

          • The Original Character August 10, 2014 3:14 am 

            Lies!!!!

          • The real creator August 14, 2014 7:08 am 

            No actually its me

      • ducanh January 8, 2014 8:27 pm  Reply

        why?

      • dsadsda May 3, 2014 3:02 pm  Reply

        the freaking mirror is 1.5.x

    • ola k ase April 30, 2013 7:28 am  Reply

      elo guat doinj

    • ola k ase April 30, 2013 7:30 am  Reply

      You wait 5 seconds and click in Download NOW! later play the game

    • chicken May 19, 2013 2:53 am  Reply

      Both versions give me a black screen! What do I do!

      • said June 2, 2013 9:31 pm  Reply

        chicken did you delete themeta inf folder? if u didnt go to you minecraft jar and delete meta inf

        • chris July 6, 2013 6:26 am  Reply

          are u sure? last time i did that minecraft gave a black screen

          • a August 6, 2013 5:59 am 

            then u didnt deleat it it doenst give u black screen Srry 4 bad spelling little cousin messed w/ auto correct)

          • BHLstudios January 26, 2014 3:00 am 

            @ a
            Some people never use spell check. Go do your little homework and learn how to spell.
            Messed up spell check is not an excuse.

        • I Like Trains Kid November 2, 2013 2:18 pm  Reply

          I like trains.

          • xRii March 23, 2014 11:14 pm 

            I like trains, too.

          • Sjonnie April 20, 2014 9:20 pm 

            TUUUT!!! BOOOOOOOOM!!!

          • Annoymous June 9, 2014 12:26 am 

            Yes you do.

          • AlexdoesMC September 26, 2014 2:50 am 

            oh hell no I Like Trains Kid,hell no.

            “I Like Trains”
            -asdfmovie1-7

        • rinko March 10, 2014 9:46 am  Reply

          c pour MAC je crois

      • BHLstudios January 26, 2014 2:58 am  Reply

        You could of ran out of RAM if you have other mods, maybe just a mod conflict (again if you have other mods.) But if you have a mac, you do not need to bother with deleting meta.inf, as mac does not care about modding clashing with mine craft security.

      • Rman February 5, 2014 11:31 pm  Reply

        Are you playing in the browser? Mods won’t work if you are.

    • aiden October 21, 2013 1:47 am  Reply

      ya well it made me have a problem with a mod

    • asdf movie November 10, 2013 8:01 pm  Reply

      die potato

      • No Name January 5, 2014 10:30 am  Reply

        NOOOOOOOOOOOOOOOO

      • Annoymous June 9, 2014 12:26 am  Reply

        Not this time!

      • Potato September 26, 2014 2:51 am  Reply

        Not Today!!!

    • hggigefe November 24, 2013 8:41 pm  Reply

      AD.FLY ISN’T WORKING WTF IS THE PROBLEM HERE

      • BHLstudios January 26, 2014 3:03 am  Reply

        See the thing that says SKIP AD in the top right corner? It should appear after 5 seconds. DO NOT click on the ad, it will either start a virus download, or it will lead you to a scam. The ad usually looks a video on how to make money, or diet facts, or a music mp3 free download. Or even a fake download page.

      • BHLstudios January 26, 2014 3:06 am  Reply

        Change your username to your own. You can’t defy a person that KNOWS how to spell ThnxCya’s username. ThxCya does not exist.

    • ant_kat December 10, 2013 5:18 pm  Reply

      How do i install icun util do i drag it into my mods folder?

    • this blows! February 11, 2014 3:20 pm  Reply

      it says it need forge right? Then y did forge hate it? i dont get it, i use ichunutil 1.6 with forge 1.7.2 it crashes, pls tell me if forge 1.7 just hates ichunutil 1.6 or something! pls i ow cant play my games

      • this doesn't blow! February 20, 2014 8:29 pm  Reply

        1.6 mods are not compatible with 1.7. Maybe you should use forge 1.6.

        • RedYoshikira May 28, 2014 2:35 am  Reply

          I tried the portal and gravity gun mods that are for 1.7 versions, but when I switch to different profiles, the client keeps saying and when I replace it, doens’t work, and then I use different vers, the client gets the error as if it still had META-INF, which I removed.

          • James May 31, 2014 11:55 pm 

            Those mods are not for 1.7 yet

      • Clashing_Skies March 26, 2014 12:20 pm  Reply

        You need to download any version of Minecraft Forge. (I use 1.6.4 cuz it works better) And download the “installer*” 1.6.4 and download the client. Once done you have a new minecraft profile and version. Play on the new version you got and play with the “forge” profile it gives you and make sure it works. Then you should have a new folder in the .minecraft folder called “mods” (If not just make one) Then drag the mod with The version you have downloaded (I use 1.6.4) into the mods folder. Lastly load up Minecraft with the new profile and version and it should have the mod active. (Instead of “3 mods” in the corner it should say “4 mods” If the mod you want is the only mod in the “mods” folder) Play on a world and the mod is downloaded! Enjoy! (If game crashes at start then mod isn’t compatible with Forge version you are playing on)

    • Thesbeta March 26, 2014 11:06 pm  Reply

      …Mod authors only upload to sites like CreeperRepo, they don’t have access to fix it if it goes down.

    • Andrew April 2, 2014 2:42 am  Reply

      It doesn’t work,I put the portal gun .jar file and the ichuntool like a folder(not .zip or .jar) .am I doing something wrong please REPLY!!!!!!

    • redstoner June 8, 2014 4:03 pm  Reply

      i trought the problem is fixed for now
      i downloaded more things from creeperhost and sometimes it is a little glitchy but try it the next day mabye it will work

    • Furballswift June 17, 2014 12:29 pm  Reply

      i need help please which one do i download for 1.6.4 it will let me download but i cant play minecraft it says something about the lowest i can do is 3.0.0 but i want 1.6.4

      • hmmmm... August 19, 2014 3:12 am  Reply

        I don’t think iChun’s 1.6 mods need iChunUtil, I’m not sure.

    • brady June 28, 2014 7:08 am  Reply

      Well I cant load it it dosnt crash but there is a screen telling me im doing something wrong (1.7.2)

  2. mauro March 18, 2013 5:58 pm  Reply

    please check link

  3. Kyle Brookes March 19, 2013 4:17 am  Reply

    Thank u! jscooly555 Join My Server At 256.525.256.789:25565

    • Jonas March 25, 2013 7:59 pm  Reply

      NO!

    • jscooly555|piglord August 6, 2013 2:13 am  Reply

      thx for what?

  4. tony March 20, 2013 1:09 am  Reply

    ur gay

      • That guy you see in the magazines January 15, 2014 10:14 am  Reply

        You too!

  5. Koondawg33 March 23, 2013 3:38 am  Reply

    Is adf.ly down right now?

    • RAndomDude October 14, 2013 11:48 pm  Reply

      No. If you’re using chrome, then you may have to re-install it, I had to do so, but it works fine now.

      • hggigefe November 24, 2013 8:41 pm  Reply

        it dosent work for me either and im using firefox

  6. TheoIsAwesomeHi-iChun March 25, 2013 2:10 am  Reply

    In order to run the portal gun mod you need iChun Util, that I know, but do you need forge in order to run it too?

    • Candy49997 March 29, 2013 1:36 pm  Reply

      all good mods use forge these days…

      • EnderShadeMC April 6, 2013 6:05 pm  Reply

        THATS CAUSE FORGE ROCKS!!!

        • sillyjake August 1, 2013 11:00 am  Reply

          No. Because good modders use forge.

      • EM May 16, 2013 2:07 pm  Reply

        I have a few good mods for Forge but MOST of my desired mods use Modloader… iChun’s Portal and Grav gun mod keep me on Forge. :)

        • IDK July 3, 2013 1:35 am  Reply

          Wow. Mods that use ModLoader SUCK! All the most popular mods (IC2, EE3, BuildCraft, NEI, etc.) use Forge.

          • FGHIK July 21, 2013 8:14 am 

            modloader mods should work on forge

          • The4thRemnant August 14, 2013 2:10 pm 

            Modloader mods are great for those who have terrible computers. Besides some of the good mods are on Modloader.

  7. Coro March 25, 2013 10:23 pm  Reply

    He said you specifically do with the new build, apparently tekkit lite (technic launcher) installs it automatically. Even so I have had a hard time getting it to work for some reason.

  8. Chainmanner March 26, 2013 9:59 am  Reply

    So what this involves is updating obfuscation. On it’s own! You, my friend, are one hell of a problem solver! I can’t believe you didn’t use this earlier and that other modders didn’t use it! :)

    • idk April 6, 2013 5:05 am  Reply

      How did you get face?

  9. Ron March 27, 2013 6:43 am  Reply

    what do i do if both link the download and the mirror dont work?

  10. DezDarkshard March 30, 2013 1:55 pm  Reply

    Apparently, this mod doesn’t work with Forge Modloader 1.5.1 and further, please fix this

    • u failed February 11, 2014 3:27 pm  Reply

      it does work, it just screws up on 1.7 and above

  11. gio March 31, 2013 11:29 pm  Reply

    do you extract the file?

    • RedYoshikira May 28, 2014 2:37 am  Reply

      I’m not sure but the main answer is no.

  12. InvincibleDave April 4, 2013 5:00 am  Reply

    I Keep downloading MC Forge, and its not working along with the mod, even with iChun!

  13. InvincibleDave April 4, 2013 5:01 am  Reply

    IM SO MAD

  14. InvincibleDave April 4, 2013 5:01 am  Reply

    ICHUN HELP ME

    • iChunUtil February 11, 2014 3:27 pm  Reply

      ok what do u want to ask?

  15. Th3Mau5Tr4p April 5, 2013 3:02 am  Reply

    how are you supposed to use the ichun util

  16. idk April 6, 2013 5:02 am  Reply

    Forge says it is missing a file

  17. idk April 6, 2013 5:03 am  Reply

    IK PEOPLE WHO DOWNLOADED IT, BUT IT DOES NOT WOrK FoR Me!!!!!!!!!!!!!

  18. idk April 6, 2013 5:03 am  Reply

    IK PEOPLE WHO DOWNLOADED IT, BUT IT DOES NOT WOrK FoR Me!!!!!!!!!!

  19. idk April 6, 2013 5:04 am  Reply

    PLZ REPLY

  20. UncopyrightTNT April 6, 2013 10:22 am  Reply

    Fix the util NOW NOW NOW NOW NOW NOW NOW NOW NOW NOW NOW NOW!!!

  21. John Smith April 6, 2013 6:46 pm  Reply

    I drag it into mods and I have the right Forge version, but when I start up MC the screen goes black

    • Some guy April 28, 2013 8:36 am  Reply

      Did you delete the META.INF file?
      :/

  22. Brandon April 11, 2013 4:08 am  Reply

    Portal Gun 1.5.1:

    Got it to work, kinda, until I actually shoot the Portal Gun. I can see the model and everything, but shooting it just crashes my game. I’m using Minecraft Version 1.5.1 & Forge 1.5.1.

    Anyways, seen gameplay of this mod and it looks fantastic. Great work!

    • EtCetera May 21, 2013 2:58 am  Reply

      Ditto someone help

    • ThatPortal2Fan January 27, 2014 12:04 am  Reply

      Maybe it’s cuz 1.5.1 is like a snapshot I believe cuz snapshots usually get really buggy n’ stuff. (but I still don’t know if 1.5.1 is a snapshot or not I just forgot it)

  23. Anonymous April 13, 2013 8:24 am  Reply

    this ichun utlility mod is not compatible with the newest forge and minecraft. despite that you put “Later” there is a clear malfunction in the mod. without it you cant run portal, now making both mods useless until they are updated. please fix this as soon as you can

  24. dudeIsAwesome April 14, 2013 10:52 pm  Reply

    nice mod!

  25. Lul April 18, 2013 8:01 pm  Reply

    How can i install it?

  26. davide98 April 21, 2013 8:07 pm  Reply

    can give me permission to put this beautiful mod in my modpack?

  27. MadLight April 24, 2013 1:19 am  Reply

    Well, utlility mod is definitely broken.

  28. sebastian April 27, 2013 7:14 am  Reply

    YO QUE AGO TENGO LA 1.5.1 EN DONDE LE DOY?’???????????? MIERDA

  29. sebastian April 27, 2013 7:16 am  Reply

    IJUE PUTA NO SIRVE IDIOTA ESTUPIDO DE MIERDA TONTO

    • Mama de sebastian August 8, 2014 11:18 pm  Reply

      No digas groserias!

  30. moy_luna April 27, 2013 7:35 am  Reply

    Hello, this is the first time i am installing a mod into minecraft (Portal gun mod.) i just wanted to ask for some help on this first time set up. what should i do to have this mod run right?

  31. KillerFusion April 29, 2013 5:04 am  Reply

    It took me several hours to figure this out, i found the instructions below on another thread , i have edited them for those not familiar with mods

    If you were all doing the same as me then this will help. I was failing on number 5! dont unzip the ichun util and trailmix mods!

    HERE’S THE INSTALLATION

    1. Download latest forge universal from here: files.minecraftforge.net

    2. Download the trail mix mod zip and ichun util zip files.

    3. Delete META-INF folder in minecraft.jar (to find you minecraft.jar, open start menu and type %appdata% into the search bar and hit enter, click on the .minecraft folder, click on bin folder, you should now be staring at minecraft.jar. you will have to open it with winrar or 7zip etc.)

    4. Drag ALL the MCForge files into the minecraft.jar

    5. Go to the mods folder and drag and drop the trail mix and ichun util ZIP FILES (DO NOT EXTRACT INTO A FOLDER) into your mods folder. (mods folder might not appear until you have run once with forge installed!)

    6. This is finished! Now go ride some flying pigs!

    • I dunno...Bob? March 1, 2014 10:52 am  Reply

      Looks like it works…just one problem. I don’t have a bin file XD

      • RedYoshikira May 27, 2014 11:37 pm  Reply

        If you do not have a binary folder, right-click on your launcher jar exe and open it with WinRAR, and delete META-INF, close out and try launching your game with mods in the mods folder.

  32. Markus Staudinger April 30, 2013 8:47 am  Reply

    Portal gun requires 1.5.0, can you update it. I think that’s why I have no sound.

  33. moziah May 2, 2013 2:44 am  Reply

    why is it 1.0.1 when miencraft is 1.5.1

  34. cheerbear1234 May 2, 2013 7:35 am  Reply

    can you put back portal2 in the mod plz and making work of bukkit server thx you

  35. The man in your ear May 3, 2013 3:16 pm  Reply

    Does it work for 1.5.2

  36. vincent May 4, 2013 8:12 am  Reply

    Will it work with 1.5.2

  37. Joe May 5, 2013 12:33 am  Reply

    If you try to add this into a private ftb pack, which mad file does it go under? Core, Jar, or the Mods folder?

    • vincent May 5, 2013 12:42 am  Reply

      mod folder

  38. Linus Persson May 5, 2013 3:08 am  Reply

    is this for minecraft 1.5.1?

  39. jscooly555|piglord May 7, 2013 1:39 am  Reply

    Make it for 1.5.2 or I cant do mod showcases for your mods!

  40. GamerfanaticMC May 11, 2013 4:44 am  Reply

    Why your donation only go until 1st of Sep? I start working at 1st of Sep :S

  41. cesar9810 May 12, 2013 3:49 am  Reply

    no me funciona pero me dise que no sirve pero le di force update y la 1.1 y me sirvio!

  42. MarkTheDARK1 May 12, 2013 9:31 am  Reply

    once i install the IChun, what do i do?

  43. kiler May 13, 2013 12:07 am  Reply

    did anyone else get a crash when using forge and ichun util

  44. kevin May 13, 2013 10:57 pm  Reply

    it freaking crashed my minecraft

  45. Серж May 15, 2013 11:12 pm  Reply

    мне надо на мой 1.5.1

  46. EtCetera May 21, 2013 2:57 am  Reply

    Whenever I try to use any of the items added by the mod it crashes minecraft….
    Help Me!

  47. Creeperssuck678 May 21, 2013 5:11 am  Reply

    When I use the portal gun, Minecraft crashes.

  48. Виктор May 21, 2013 10:39 pm  Reply

    может мне кто нибудь скажет почему в моде Portal Gun мне в чате пишет что я не могу СТАВИТЬ СЕТКУ

  49. dkluin May 26, 2013 12:55 pm  Reply

    Very good!!!! I tried and it worked!!! With my 30 other mods!

    • Di1080 July 30, 2013 7:12 pm  Reply

      Потому что её ещё не доделали

  50. mop706 May 28, 2013 7:13 am  Reply

    why does ichun util 1.0.0 not work for me? minecraft starts up then says i dont have the right version when i do! makes me so mad!

  51. brandon June 1, 2013 1:04 am  Reply

    creeperhost doesn’t work for me
    :( please use a different website insted of creeperhost

  52. Marvin June 10, 2013 8:07 pm  Reply

    I can not see through the portal and I think my items are missing

  53. _Lory_ June 14, 2013 8:33 pm  Reply

    the links do not work

  54. Anon June 15, 2013 2:19 am  Reply

    Hey can I use your iChun Util mod for a modpack?

  55. daniel June 15, 2013 3:57 am  Reply

    wtf
    is a crash in my minecraft

  56. I do not care June 16, 2013 9:54 am  Reply

    hello

  57. Nexus. June 20, 2013 10:57 am  Reply

    Is this a coremod or a jarmod?

    And is it possible to install it to FTB?

  58. Notch June 28, 2013 3:51 am  Reply

    Well this mod cant be approved for minecraft yet

    • umm November 23, 2013 3:47 am  Reply

      are you really notch

      • jesusfreak137 May 31, 2014 6:17 am  Reply

        idk that’s the right avatar

    • Ano7heR June 8, 2014 1:55 am  Reply

      Hi Notch!

  59. sackdragon June 28, 2013 5:18 pm  Reply

    iChunUtil requires 7.7.0.582 of forge and higher. Latest version of forge is 5.2.23.657. How does this work?

    • sackdragon June 28, 2013 5:22 pm  Reply

      figured it out. i was looking at forge mod loader.

  60. whats my name? July 9, 2013 8:51 am  Reply

    :oye tranquilo viejo:

  61. aperson July 10, 2013 11:50 pm  Reply

    is adfly down cuz its now working for me

  62. RadDevVan July 14, 2013 4:05 am  Reply

    you mean i can’t use your mods until i install a ichuns util

    best idea ever

  63. aass July 19, 2013 7:24 pm  Reply

    ichun util 1.0.1 links do not work please fix them!!!!

  64. flashfire100 July 27, 2013 1:16 pm  Reply

    I can not got get this THING to work!! Please help me!!! I am using Minecraft 1.5.2!

    • Derp November 25, 2013 7:16 am  Reply

      this is 1.6.4 downloads
      DERP

  65. Dan July 28, 2013 6:24 am  Reply

    Hey Ichun, can you please make the version 2 for 1.5.X? Anyone?

  66. Vicki August 10, 2013 5:48 am  Reply

    I am a mom learning how to load mods for my son. I am using 1.6.2 and Magic Launcher. How can I install your utility and Trail Mix mods?

    Thanks,
    Vicki
    Chicago

    • TheAngryBirdKing August 13, 2013 11:13 pm  Reply

      U have to have forge mod installer, and I cant get these mods to work eather.

    • slemire_meows August 21, 2013 1:27 am  Reply

      You will need the 1.6.2 forge Modloader, you may want to look up a video on how to use it though.

  67. keegan August 22, 2013 7:21 am  Reply

    Why do modders make things like this? Is it to block people from reposting the mods lol.

  68. Muffer August 22, 2013 7:49 am  Reply

    This does not work with snow biomes :P

    • Muffer August 22, 2013 7:57 am  Reply

      Derp wrong post fail

  69. supmanss August 25, 2013 9:27 pm  Reply

    how do i download it

  70. supmanss August 25, 2013 9:32 pm  Reply

    nevermind

  71. adalberto August 26, 2013 3:02 am  Reply

    hola

  72. adalberto August 26, 2013 10:09 am  Reply

    que

  73. mt August 26, 2013 10:51 am  Reply

    nice, adf.ly is down, what now?

  74. tcboy10 August 27, 2013 10:22 pm  Reply

    you install it by dropping it into the mods folder from minecraft forge

  75. Sir Taco IV August 29, 2013 2:39 am  Reply

    I got a crash :/ Here ya go:

    —- Minecraft Crash Report —-
    // Everything’s going to plan. No, really, that was supposed to happen.

    Time: 8/28/13 2:36 PM
    Description: There was a severe problem during mod loading that has caused the game to fail

    cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/client/event/RenderLivingEvent$Pre
    at cpw.mods.fml.common.LoadController.transition(LoadController.java:149)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:522)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:182)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:470)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:796)
    at net.minecraft.client.main.Main.main(SourceFile:101)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:57)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:18)
    Caused by: java.lang.NoClassDefFoundError: net/minecraftforge/client/event/RenderLivingEvent$Pre
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2475)
    at java.lang.Class.privateGetPublicMethods(Class.java:2595)
    at java.lang.Class.getMethods(Class.java:1437)
    at net.minecraftforge.event.EventBus.register(EventBus.java:33)
    at mobamp.common.MobAmputation.preLoad(MobAmputation.java:74)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:540)
    at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:194)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:174)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:105)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:521)
    … 10 more
    Caused by: java.lang.ClassNotFoundException: net.minecraftforge.client.event.RenderLivingEvent$Pre
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:179)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    … 42 more
    Caused by: java.lang.NullPointerException
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:171)
    … 44 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    – System Details –
    Details:
    Minecraft Version: 1.6.2
    Operating System: Mac OS X (x86_64) version 10.8.4
    Java Version: 1.6.0_51, Apple Inc.
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.
    Memory: 21694024 bytes (20 MB) / 95764480 bytes (91 MB) up to 1065025536 bytes (1015 MB)
    JVM Flags: 1 total; -Xmx1G
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v8.04 FML v6.2.35.804 Minecraft Forge 9.10.0.804 14 mods loaded, 14 mods active
    mcp{8.04} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized
    FML{6.2.35.804} [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized
    Forge{9.10.0.804} [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized
    shadersmod{2.0.1 beta 8} [GLSL Shaders Mod] (coremods) Unloaded->Constructed->Pre-initialized
    mods.springmine.BetterLog{1.6.2} [BetterLog] (BetterLog162.zip) Unloaded->Constructed->Pre-initialized
    SonicVisuals{0.3.0} [Enhanced Visuals] (EnhancedVisualsMod) Unloaded->Constructed->Pre-initialized
    NBTEdit{1.6.2.0} [In-game NBTEdit] (Forge_NBTEditv1.6.2.0.zip) Unloaded->Constructed->Pre-initialized
    Hats{2.0.0} [Hats] (Hats2.0.0.zip) Unloaded->Constructed->Pre-initialized
    instantmod{1.4.7} [InstantMod] (Instant-Mod162.zip) Unloaded->Constructed->Pre-initialized
    iChunUtil{2.1.0} [iChunUtil] (iChunUtil2.1.0.zip) Unloaded->Constructed->Pre-initialized
    MobAmputation{2.0.0} [MobAmputation] (MobAmputation2.0.0.zip) Unloaded->Constructed->Errored
    MobDismemberment{2.0.0} [MobDismemberment] (MobDismemberment2.0.0.zip) Unloaded->Constructed->Pre-initialized
    Morph{0.0.7} [Morph] (Morph-Beta-0.0.7.zip) Unloaded->Constructed->Pre-initialized
    PortalGun{2.0.0} [PortalGun] (PortalGun2.0.0 (1).zip) Unloaded->Constructed->Pre-initialized

    • Sir Taco IV August 29, 2013 2:40 am  Reply

      Wait, let me see if I am using the right forge

      • Sir Taco IV August 29, 2013 2:42 am  Reply

        Yeah, it’s the right version. Damn it!

        • Sir Taco IV August 29, 2013 2:43 am  Reply

          OH SHIT Wrong place to post Sorry D:

        • Sir Taco IV August 29, 2013 2:43 am  Reply

          Oh shit! I posted this in wrong area!

          • somebody_else November 26, 2013 9:06 am 

            YES U DID DUMB ASS

  76. Jakob September 5, 2013 7:05 pm  Reply

    Sentry Turret dont attack me !!! :(

  77. notadeathclaw September 5, 2013 8:01 pm  Reply

    The website is down and there is no mirror

  78. Naddox September 5, 2013 9:46 pm  Reply

    Creeper host is down, once again, and there is no mirrior for 1.6.X versions please use a different host like dropbox or mediafire. It seems every other time I come to download these creeper host is down and I’m waiting 24 hours.

  79. Derek September 7, 2013 7:29 am  Reply

    can you please change the website Creeper host to mediafire cause i cant download Ichunutil 210

  80. Connor Dargan September 13, 2013 11:55 am  Reply

    Hey can you update the forge version its set to 1.6 can you update it to 1.6.2?

  81. Mil September 13, 2013 6:13 pm  Reply

    Anyone else got the problem, that after clicking the download button the page reloads and have to wait 5 seconds again?

    • frank October 31, 2013 12:16 pm  Reply

      yeah it does this over and over…. need alternate link.

  82. Meh September 16, 2013 3:53 am  Reply

    Whenever I load minecraft,it says that ichunutil.zip or whatever has been duplicated and is causing problems.

  83. ghostboy1225 September 20, 2013 8:14 am  Reply

    i chun is thee any alternate links?
    wonderin becuase adfly wont work for me i have no idea why i have afked for over an hour and no skip ad button.

    • Greenw0lf January 11, 2014 5:50 am  Reply

      All you have to do is reaload the page… XDDD You failed!

  84. gueney99 September 30, 2013 5:49 pm  Reply

    When i have the mod iChun util i dont see the textures for the chest, the villager and my left arm!

  85. Pancho Pistola October 6, 2013 12:34 am  Reply

    My game crashes everytime i try to open the portal gun mod tab in creative mode, or any time i try to use it.

  86. Detcu October 6, 2013 4:17 pm  Reply

    I have problem with Forge when i added iChun’s util. “minimum version required is 9.10.0.789″, BUT LAST VERSION: Latest-1.6.4 6.4.21.770, wtf?

  87. Salam October 14, 2013 8:00 pm  Reply

    My Minecraft always crashes when IChan is in the mods folder. :[

  88. Salam October 17, 2013 12:59 am  Reply

    Halp pleaseee

    • Curly Brace December 19, 2013 4:20 am  Reply

      This is a scam to make people post spam comments.

  89. Blade Avuari October 23, 2013 4:23 am  Reply

    Can you please provide links without adfly? For some unknown reason, I am unable to access anything on the adfly website, excluding pinging it.

  90. Jonarthan October 27, 2013 8:29 am  Reply

    I can’t get creeperhost to work

  91. Haseo. October 30, 2013 8:27 am  Reply

    Dude, when I install Optifine with with this mod my characters body’s ripped off, please fix this..

  92. Annoyed as frick October 31, 2013 12:51 am  Reply

    Creeperhost sucks. It went down again and I can’t download any of your mods.

    Please have a link for mediafire/dropbox.

  93. frank October 31, 2013 12:14 pm  Reply

    iChunUtil2.3.0
    or any version for mc 1.6.x creeperhost wont let me download no matter what browser i use.

  94. jack November 3, 2013 8:35 am  Reply

    FUCK THIS MOD IM NOT DOING IT ICHUN SUCKS

  95. DiceBlood November 8, 2013 4:45 am  Reply

    Hi i Like The Core Mod iChunUtil2.3.0 & MobDismemberment2.0.0.

    can you update You core Mod iChunUtil2.3.0 To Work With DamageIndicators As of Now It is Makeing The Gui Flicker On Screen When The Mob Is Dismemberment. (Thanks For This Mod)

    i Hope You Can Work With The Mod maker of DamageIndicators To Get The mods To Play well

  96. ricijak November 15, 2013 12:50 am  Reply

    .creeperhost is down ,cant download ..damn need to move my ch e st~~~!!!

  97. hggigefe November 24, 2013 8:13 pm  Reply

    adfly isnt even working for me

  98. hggigefe November 24, 2013 8:14 pm  Reply

    adf.ly dosen’t work for me

  99. Derp November 25, 2013 7:14 am  Reply

    whenever i shoot the portal gun (this is latest version)
    it crashes and doesn’t work
    how do i fix it?

  100. somebody_else November 26, 2013 9:06 am  Reply

    nice mod, ICHUN

  101. Michael Jay Fox November 27, 2013 10:34 pm  Reply

    I tried playing Minecraft 1.6.2 on forge, and then it says that i have 2 iChun versions on my computer. I tried finding it, but it wasn’t there. SOMEBODY HELP ME!!!

    • Ele2000 May 1, 2014 12:46 am  Reply

      It could be in the 1.6.2 folder created in the mods folder …/.minecraft/mods/1.6.2/Ichun util. I once found this problem with forge multipart. Sometimes the mod will create its own one. It shouldn’t happen with these but chech there anyway (If your reading this. 5 months is a LONG time)

  102. MisterFrogger December 4, 2013 9:17 pm  Reply

    Downloads doesn’t work :(

  103. Protheus December 8, 2013 7:04 pm  Reply

    I have ichun util 2.4.0 for MC 1.6.4 in my mod folder installed. When I start minecraft and check the version in the mod list I see iChunutil 2.2.0.

    Not sure if that is correct ?

  104. Bombzyz December 10, 2013 7:23 am  Reply

    The Version 2.4.0 Interfere’s With the Pixelmon mod,

  105. Corny December 28, 2013 1:56 am  Reply

    Whenever I Start My Minecraft with Forge, it says: iChunUtil: minimum version required is 2.1.0
    Even though I downloaded version 2.4.0
    Can Someone please help me?

  106. soni December 29, 2013 12:47 am  Reply

    hi! i’m soni
    bye

  107. Morphox January 1, 2014 12:13 am  Reply

    Help please.

    I love Gravity Gun mod, but when i install IChunutil the minecraft mobs textures start to disappear and steve also starts to losing some textures like arms legs even is head!
    Can anybody help me ?

  108. GnoSiS January 2, 2014 7:42 am  Reply

    1.6.4

    This mod along with latest optifine causes entities to have missing limbs/textures and chests to appear without lids. This is caused by the utils mod not the portal mod.

    This causes problems for FTB – Monster + other packs that include this, since optifine is almost essential to play dor most ppl….

    • Morphox January 2, 2014 8:16 am  Reply

      So if i use a older version of optifine the problem will be solved?
      Thank you.

  109. isavegas January 5, 2014 12:48 pm  Reply

    Omg, the raining chickens caused an incredible amount of lag for me, and although they stopped falling from the sky when I disabled the easter egg, they still appear to be spawning, as I am still lagging and Opis is showing a ridiculous amount of entities popping up around my character on the minimap that I cannot find, and removing PortalGun fixes the issue.

  110. budder_is_kool January 10, 2014 5:18 am  Reply

    y isnt it workind im hiting download but my adf.ly appers to be broken

  111. Greenw0lf January 11, 2014 5:53 am  Reply

    works just fine for me i have a mac horrible internet connectoin and i installed it all in 20 seconds and it didnt crash -_-

  112. Sadness January 16, 2014 5:30 am  Reply

    As soon as it was in the mods folder, Forge Crashed without launching.

    —- Minecraft Crash Report —-
    // I let you down. Sorry :(

    Time: 1/15/14 4:26 PM
    Description: Initializing game

    java.lang.NoClassDefFoundError: net/minecraft/client/renderer/texture/IconRegister
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:441)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:205)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:185)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:116)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:487)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:179)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:495)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:849)
    at net.minecraft.client.main.Main.main(SourceFile:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    Caused by: java.lang.ClassNotFoundException: net.minecraft.client.renderer.texture.IconRegister
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    … 35 more
    Caused by: java.lang.NullPointerException
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:180)
    … 37 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    – Head –
    Stacktrace:
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:441)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:205)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:185)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:116)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:487)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:179)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:495)

    – Initialization –
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:849)
    at net.minecraft.client.main.Main.main(SourceFile:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    – System Details –
    Details:
    Minecraft Version: 1.7.2
    Operating System: Windows 7 (x86) version 6.1
    Java Version: 1.7.0_21, Oracle Corporation
    Java VM Version: Java HotSpot(TM) Client VM (mixed mode, sharing), Oracle Corporation
    Memory: 55245480 bytes (52 MB) / 162684928 bytes (155 MB) up to 518979584 bytes (494 MB)
    JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx512M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.01-pre FML v7.2.59.999 Minecraft Forge 10.12.0.999 5 mods loaded, 5 mods active
    mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed
    FML{7.2.59.999} [Forge Mod Loader] (forge-1.7.2-10.12.0.999.jar) Unloaded->Constructed
    Forge{10.12.0.999} [Minecraft Forge] (forge-1.7.2-10.12.0.999.jar) Unloaded->Constructed
    iChunUtil{2.4.0} [iChunUtil] (util^iChunUtil2.4.0.zip) Unloaded
    PortalGun{2.0.2} [PortalGun] (PortalGun2.0.2.zip) Unloaded
    Launched Version: 1.7.2-Forge10.12.0.999
    LWJGL: 2.9.0
    OpenGL: ATI Radeon HD 4270 GL version 3.3.9836 Compatibility Profile Context, ATI Technologies Inc.
    Is Modded: Definitely; Client brand changed to ‘fml,forge’
    Type: Client (map_client.txt)
    Resource Packs: []
    Current Language: English (US)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
    Anisotropic Filtering: Off (1)

    • LloydoE April 20, 2014 9:08 pm  Reply

      I seem to have the same problem. Looks like it wont construct any of the mods after inchun util, yet nothing is errored. Please help us out!

  113. Stuff January 24, 2014 5:46 am  Reply

    How I put the stuff in where they belong( I think(. Now where do you put the iChun Folder?

  114. yo momma January 31, 2014 10:18 am  Reply

    im using 1.7.4 but installed forge and then used skydaz to get the 1.6.4 portal gun mod and when the mod installer loaded It let me select 1.7.4 soo then I got on minecraft and It added a account named forge but when I hit play it closes out of the launcher

  115. ryan February 1, 2014 10:12 am  Reply

    what folder to i put the util in

  116. Anonymous February 2, 2014 10:56 pm  Reply

    I have discovered a glitch. If iChun Util and Optifine are loaded with the latest 1.6.4 version of Forge Modloader, then you will commonly see mobs with body parts missing or textured incorrectly, i.e. a cow missing its tordo with the legs given the stone texture. Please fix this!

  117. tanner February 9, 2014 10:08 am  Reply

    it says i need minium 2.1.0 although i have iChunItl 2.1.0. any help?

    • RedYoshikira May 27, 2014 11:41 pm  Reply

      I have the same problem, but I have iChunUtil 2.4.0
      :( FK!! WHEN ARE THESE GONNA WORK?

  118. Ethan February 10, 2014 6:56 am  Reply

    Okay so I have downloaded Minecraft Forge along with the iChun Util mod and placed it in the mods folder. I have not extracted the files. I have downloaded Sync Mod and placed it in the mods folder but whenever I run Minecraft, it goes black and gives me this report of why it crashed.

    Someone please help me, because I have been trying all day to get these mods installed and nothing ever works.

    I am using 1.7.2 and I did delete the META-INF folder. If iChun could help, that would be splendid. Otherwise, I would love some advice.

  119. Ethan February 10, 2014 7:50 am  Reply

    Any help?!

  120. Rubie February 10, 2014 11:24 pm  Reply

    Where is 1.7.4????

  121. Gremmlin06 February 18, 2014 1:17 am  Reply

    I have installt ichun util with forge 1.6.2 on my 1.6.2 Profile but it always sas you need a newer Version of forge although it is the newestvrsion for 1.6.2
    Please help

  122. paja February 21, 2014 8:14 pm  Reply

    ? Mods portal 2

  123. Jim February 23, 2014 10:01 am  Reply

    i cant download 2.4.0 because creeper host wont load is there a mirror?

  124. QWERTY_UIVER March 13, 2014 10:34 pm  Reply

    Could I get your permission to use this your util, hats, morph, and hat stand mods in a modpack that I am working on? I will give you credit…

  125. Lillibilli March 16, 2014 7:31 am  Reply

    When i installed it and loaded up minecraft it was fine but when i loaded my save it crashed:
    —- Minecraft Crash Report —-
    // Daisy, daisy…

    Time: 15.3.2014 23:22
    Description: Unexpected error

    java.lang.NullPointerException
    at ichun.client.core.TickHandlerClient.resetWorld(TickHandlerClient.java:126)
    at ichun.client.core.TickHandlerClient.tickEnd(TickHandlerClient.java:48)
    at cpw.mods.fml.common.SingleIntervalHandler.tickEnd(SingleIntervalHandler.java:34)
    at cpw.mods.fml.common.FMLCommonHandler.tickEnd(FMLCommonHandler.java:141)
    at cpw.mods.fml.common.FMLCommonHandler.onPostClientTick(FMLCommonHandler.java:367)
    at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1981)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:915)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:840)
    at net.minecraft.client.main.Main.main(SourceFile:101)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.multimc.onesix.OneSixLauncher.launch(OneSixLauncher.java:214)
    at org.multimc.EntryPoint.listen(EntryPoint.java:139)
    at org.multimc.EntryPoint.main(EntryPoint.java:53)

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    – System Details –
    Details:
    Minecraft Version: 1.6.4
    Operating System: Windows 7 (x86) version 6.1
    Java Version: 1.7.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    Memory: 403685512 bytes (384 MB) / 682979328 bytes (651 MB) up to 1037959168 bytes (989 MB)
    Mod Pack: Unknown / None
    LiteLoader Mods: 0 loaded mod(s)
    JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xms512m -Xmx1024m -XX:PermSize=64m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 2, tallocated: 64
    FML: MCP v8.11 FML v6.4.49.965 Minecraft Forge 9.11.1.965 47 mods loaded, 47 mods active
    mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    FML{6.4.49.965} [Forge Mod Loader] (minecraftforge-9.11.1.965.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Forge{9.11.1.965} [Minecraft Forge] (minecraftforge-9.11.1.965.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MMM_metaworlds_patcher{0.985} [Metaworlds_patcher] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CodeChickenCore{0.9.0.9} [CodeChicken Core] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    NotEnoughItems{1.6.1.9} [Not Enough Items] (NotEnoughItems 1.6.1.9.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    TConstruct-Preloader{0.0.1} [Tinkers Corestruct] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BiomesOPlenty{1.2.1} [Biomes O' Plenty] (BiomesOPlenty-universal-1.6.4-1.2.1.434.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Core{4.2.2} [BuildCraft] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Builders{4.2.2} [BC Builders] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Energy{4.2.2} [BC Energy] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Factory{4.2.2} [BC Factory] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Transport{4.2.2} [BC Transport] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    BuildCraft|Silicon{4.2.2} [BC Silicon] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    ChickenChunks{1.3.3.4} [ChickenChunks] (ChickenChunks 1.3.3.4.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CoFHCore{2.0.0.2} [CoFH Core] (CoFHCore-2.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CoFHLoot{2.0.0.2} [CoFH Loot] (CoFHCore-2.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CoFHMasquerade{2.0.0.2} [CoFH Masquerade] (CoFHCore-2.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CoFHSocial{2.0.0.2} [CoFH Social] (CoFHCore-2.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    CoFHWorld{2.0.0.2} [CoFH World] (CoFHCore-2.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    EnderStorage{1.4.3.6} [EnderStorage] (EnderStorage 1.4.3.6.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    EE3{0.1.0} [Equivalent Exchange 3] (EquivalentExchange3-1.6.4-0.1.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    LomLib{1.2.0} [LomLib] (LomLib-universal-1.2.0.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Equivalency{1.6.4} [Equivalency] (Equivalency-universal-1.6.4.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    ExtraUtilities{1.0.3a} [Extra Utilities] (extrautils-1.0.3a.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    ForgeMultipart{1.0.0.219} [Forge Multipart] (ForgeMultipart-universal-1.6.4-1.0.0.219.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    ThermalExpansion{3.0.0.2} [Thermal Expansion] (ThermalExpansion-3.0.0.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    IC2{2.0.396-experimental} [IndustrialCraft 2] (industrialcraft-2_2.0.396-experimental.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Forestry{2.3.1.0} [Forestry for Minecraft] (forestry-A-2.3.1.0.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsMod{0.985} [MetaworldsMod] (metaworlds_core.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsControlsAlignMod{0.985} [MetaworldsControlsAlignMod] (metaworlds_controller.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsControlsCaptainMod{0.985} [MetaworldsControlsCaptainMod] (metaworlds_controller.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsBlankCreatorMod{0.985} [MetaworldsBlankCreatorMod] (metaworlds_creator.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsContagiousCreatorMod{0.985} [MetaworldsContagiousCreatorMod] (metaworlds_creator.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    MetaworldsMiniatureMod{0.985} [MetaworldsMiniatureMod] (metaworlds_miniaturization.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    numina{0.1.2-55} [Numina] (Numina-1.6.2-0.1.2-55.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    powersuits{0.10.0-91} [MachineMuse's Modular Powersuits] (ModularPowersuits-1.6.4-0.10.0-91.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Morph{0.7.1} [Morph] (Morph-Beta-0.7.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    NEIPlugins{1.1.0.6} [NEI Plugins] (NEIPlugins-1.1.0.6.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    powersuitaddons{@VERSION@} [Andrew's Modular Powersuits Addons] (powersuitaddons-1.6.4-884.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Redstone Arsenal{1.0.0.0} [Redstone Arsenal] (RedstoneArsenal-1.0.0.0.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    TConstruct{1.6.X_1.5.3dev} [Tinkers' Construct] (TConstruct_mc1.6.4_1.5.3.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    Thaumcraft{4.1.0g} [Thaumcraft] (Thaumcraft4.1.0g.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    TMechworks{19.d4b8fa0} [Tinkers' Mechworks] (TMechworks_mc1.6.4_0.1.4.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    iChunUtil{2.3.0} [iChunUtil] (util^iChunUtil2.3.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    McMultipart{1.0.0.219} [Minecraft Multipart Plugin] (ForgeMultipart-universal-1.6.4-1.0.0.219.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    ForgeMicroblock{1.0.0.219} [Forge Microblocks] (ForgeMultipart-universal-1.6.4-1.0.0.219.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available
    TConstruct Environment: Sane and ready for action. Bugs may be reported.
    Launched Version: 1.6.4
    LWJGL: 2.9.0
    OpenGL: GeForce GT 640/PCIe/SSE2 GL version 4.3.0, NVIDIA Corporation
    Is Modded: Definitely; Client brand changed to ‘fml,forge’
    Type: Client (map_client.txt)
    Resource Pack: Default
    Current Language: English (US)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

    • Lillibilli March 16, 2014 7:33 am  Reply

      Might i add this was the 5th test to see which mod it was and i removed ichun utils and it worked. Put it back in and it crashed

  126. Michael March 16, 2014 6:13 pm  Reply

    I want to use this in Minecraft 1.7.2 or 1.7.5. Any plans to upgrade? I can’t get it to work in 1.6.4 or other versions – it keeps crashing.

  127. PPeop March 22, 2014 3:42 am  Reply

    how Do You Make A Portal? It Dosent Work

    • Ele2000 May 1, 2014 12:41 am  Reply

      You need to download the portal gun mod AS WELL as the library it takes info from (Ichun util)

  128. maths March 22, 2014 3:18 pm  Reply

    comment on fait pour telecharger le mod portalgun

  129. evann March 22, 2014 3:20 pm  Reply

    comment faites-vous pour télécharger portal gun

  130. crash March 22, 2014 7:05 pm  Reply

    I want to use this iChun Util. But this mod do not work in my minecraft. my minecraft is 1.7.2 and forge is installed.Do this mod work in ver1.7.2?please teach me.

    • Ele2000 March 24, 2014 2:09 am  Reply

      This mod only allows support for others of his mods and is currently only for 1.6.x and 1.5.x. 1.7.x eg. 1.7.2 isn’t supported yet. For now play on 1.6.4 (Download 1.6.4 forge and change to that profile(If you have any mods for 1.7.2 already there then you will have to clear the mods folder of 1.7.2 mods first)) or Wait for it to update. Sorry if I dragged on and i hope this comment has helped.

  131. crash March 24, 2014 4:21 pm  Reply

    Ah, so that’s how it is. thanks for your answer.i wait to supported 1.7.2.

  132. mahan April 1, 2014 8:00 am  Reply

    i want the mod so bad but it wont work now :(

  133. absentandimprovd April 12, 2014 10:50 am  Reply

    hey can u look at the resent one 2.4.0 i have been trying to use your mods but it doesnt allow me to and crashes everytime and when i go down a update it says one of my mods require 2.4.0 plz fix this and thx

  134. Ray Green April 17, 2014 12:40 am  Reply

    How do I install it on my forge server ?
    When i drop the zip file into the mods file, i cant start the server it crashes

    • Ray Green April 17, 2014 12:41 am  Reply

      folder* into the mods folder.

  135. will April 19, 2014 4:06 am  Reply

    what folder does the download go in for forge

  136. will April 19, 2014 4:15 am  Reply

    when I download Ichunutil I did because I had a error message that said I need it for forge but i don’t now what folder I need to put it in to make forge work.

    • Ele2000 May 1, 2014 12:40 am  Reply

      When you install forge, it should make a folder called “mods” in the .minecraft folder (in roaming found by typing “%appdata%” in the search bar). Put the zip in there for the relevent version of minecraft (e.g. 2.4.0 for minecraft (and forge) 1.6.4) and run minecraft on that profile. As long as you do that then it should work

  137. falco1010 April 24, 2014 2:40 am  Reply

    There is still a bug with optifine and Ichun Util . When is there going to be an update ? :D

    • Ele2000 May 1, 2014 12:40 am  Reply

      Are you using the latest version of optifine for 1.6.4?

  138. Tyler Burgess May 3, 2014 9:55 am  Reply

    Hey, yea the Creeperhost download page for this mod is rather broken. I dont see a download option even in the mess. :/

    • Timothy May 3, 2014 10:01 am  Reply

      I agree, I go to the page and try every single clickable button, but none download it. Could someone please help me get this required mod?

  139. shrike2048 May 9, 2014 1:22 am  Reply

    when did ichun Util will be updated for minecraft 1.7 and more,there’s portal gun and gravity gun for 1.7.2 but i find no ichunutil for 1.7.2 or 1.7.4 or now for 1.7.9,but the crash report say me i need a 1.7.x version of ichunutil

  140. BlazeTNT May 11, 2014 9:59 pm  Reply

    Dafaq Just Happen
    —- Minecraft Crash Report —-
    // Quite honestly, I wouldn’t worry myself about that.

    Time: 5/11/14 9:56 PM
    Description: Initializing game

    java.lang.NoClassDefFoundError: cpw/mods/fml/common/ITickHandler
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:420)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:209)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:188)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:119)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:484)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:201)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:498)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:853)
    at net.minecraft.client.main.Main.main(SourceFile:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    Caused by: java.lang.ClassNotFoundException: cpw.mods.fml.common.ITickHandler
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    … 35 more
    Caused by: java.lang.NullPointerException
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:180)
    … 37 more
    ————————————————————————

    Pls Help:ccc

  141. fjhus16 May 13, 2014 2:09 am  Reply

    When are you going to start updating mods to 1.7.2? I miss your mods!

  142. jack May 13, 2014 3:04 am  Reply

    what one for 1.7.2

  143. slendermansean May 18, 2014 2:06 pm  Reply

    I try to download but freaking adfly keeps blocking it

  144. Mattmatts May 22, 2014 7:59 am  Reply

    Do you have to RUN this?

  145. JadeHunterKato May 24, 2014 3:11 am  Reply

    Cant wait for the 1.7.X version of this and portal mod

  146. WaterGal May 28, 2014 12:02 pm  Reply

    I put the IChun Util into my mods folder, run minecraft, but it just crashes. Any Tips??

  147. CRZY June 6, 2014 6:23 pm  Reply

    Hey , Ichun when i downloaded some of your mods for 1.6.4 it siad i need iChunUtil 3.0.0 but 3.0.0 is only for 1.7 what do i do?

  148. same June 7, 2014 2:57 am  Reply

    here… ant join the world cause Mincraft asking me Uchunutil 3.0 im runibng a 1.6.4 modpack client. lots of mods and this is the only on conflicting. any idea of the Real Matchs? like Ichunutil3.0 goes with all MC bversion from 1.6.x to .etc? THAT… DUMB PROOF plz.

  149. The Do The Flop Guy June 8, 2014 1:54 am  Reply

    EVERYBODY DO THE FLOP!!!

  150. Yvanoyl June 8, 2014 8:40 pm  Reply

    —- Minecraft Crash Report —-
    // This is a token for 1 free hug. Redeem at your nearest Mojangsta: [~~HUG~~]

    Time: 08/06/14 14:35
    Description: Initializing game

    java.lang.NoClassDefFoundError: cpw/mods/fml/common/IPlayerTracker
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:420)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:208)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:187)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:118)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:491)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:204)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:815)
    at net.minecraft.client.main.Main.main(SourceFile:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    Caused by: java.lang.ClassNotFoundException: cpw.mods.fml.common.IPlayerTracker
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    … 35 more
    Caused by: java.lang.NullPointerException
    at org.objectweb.asm.ClassReader.(Unknown Source)
    at codechicken.lib.asm.ASMHelper.createClassNode(ASMHelper.java:113)
    at codechicken.lib.asm.ASMHelper.createClassNode(ASMHelper.java:107)
    at codechicken.core.asm.DefaultImplementationTransformer.transform(DefaultImplementationTransformer.java:84)
    at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:276)
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:174)
    … 37 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    – Head –
    Stacktrace:
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:420)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:208)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:187)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:118)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:491)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:204)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)

    – Initialization –
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:815)
    at net.minecraft.client.main.Main.main(SourceFile:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    – System Details –
    Details:
    Minecraft Version: 1.7.2
    Operating System: Windows 8.1 (amd64) version 6.3
    Java Version: 1.7.0_55, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 25470920 bytes (24 MB) / 161878016 bytes (154 MB) up to 1037959168 bytes (989 MB)
    JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.03 FML v7.2.207.1111 Minecraft Forge 10.12.1.1111 Optifine OptiFine_1.7.2_HD_U_D1 24 mods loaded, 24 mods active
    mcp{9.03} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed
    FML{7.2.207.1111} [Forge Mod Loader] (forge-1.7.2-10.12.1.1111.jar) Unloaded->Constructed
    Forge{10.12.1.1111} [Minecraft Forge] (forge-1.7.2-10.12.1.1111.jar) Unloaded->Constructed
    CodeChickenCore{rc_} [CodeChicken Core] (minecraft.jar) Unloaded->Constructed
    NotEnoughItems{rc_} [Not Enough Items] (NotEnoughItems-1.7.2-rc2.jar) Unloaded->Constructed
    DamageIndicatorsMod{3.1.0} [Damage Indicators] ([1.7.2]DamageIndicatorsMod-3.1.0.jar) Unloaded->Constructed
    iChunUtil{3.1.0} [iChunUtil] (iChunUtil-3.1.0.jar) Unloaded->Constructed
    BackTools{3.0.1} [BackTools] (BackTools-3.0.1.jar) Unloaded->Constructed
    BiblioCraft{1.6.3} [BiblioCraft] (BiblioCraft[1.6.3][MC1.7.2].jar) Unloaded->Constructed
    Blocks3D{1.7.2.1} [3D Blocks Mod] (Blocks3DMod-1.7.2.1.jar) Unloaded->Constructed
    flansmod{4.2.3} [flansmod] (Flans Mod-1.7.2-4.2.3.jar) Unloaded->Constructed
    inventorytweaks{1.57-116} [Inventory Tweaks] (InventoryTweaks-1.57-116.jar) Unloaded->Constructed
    IronChest{6.0.26.721} [Iron Chest] (ironchest-1.7.2-6.0.26.721-universal.jar) Unloaded->Constructed
    MoreSwordsMod{2.6.1} [More Swords Mod] (More Swords Mod 2.6.1 For 1.7.2.jar) Unloaded->Constructed
    MoreFurnaces{1.3.6} [More Furnaces] (MoreFurnaces-1.3.6-MC1.7.2.jar) Unloaded->Constructed
    mysticores{0.1} [Mystic Ores] (Mystic-Mods-1.7.2.jar) Unloaded->Constructed
    mysticruins{0.1} [Mystic Ruins] (Mystic-Mods-1.7.2.jar) Unloaded->Constructed
    mysticstones{0.2} [Mystic Stones] (Mystic-Mods-1.7.2.jar) Unloaded->Constructed
    mysticworld{0.1a} [Mystic World] (Mystic-Mods-1.7.2.jar) Unloaded->Constructed
    pda{1.7.2} [Plus d'aliments] (Plus daliments-1.7.2.jar) Unloaded->Constructed
    PortalGun{2.0.2} [PortalGun] (PortalGun2.0.2.zip) Unloaded
    TLSpecialArmor{1.7.2} [TeeLuk's SpecialArmor] (TLSpecialArmor-1.7.2.jar) Unloaded
    voxelmap{1.7.2} [VoxelMap] (voxelmap-1.7.2-1.0.jar) Unloaded
    wildcaves3{0.4.3.5} [Wild Caves 3] (WildCavesMod1.7.2.jar) Unloaded
    Launched Version: 1.7.2-Forge10.12.1.1111
    LWJGL: 2.9.0
    OpenGL: AMD Radeon HD 8210 GL version 4.4.12874 Compatibility Profile Context 14.100.0.0, ATI Technologies Inc.
    Is Modded: Definitely; Client brand changed to ‘fml,forge’
    Type: Client (map_client.txt)
    Resource Packs: [faithful32pack.zip]
    Current Language: Français (France)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
    Anisotropic Filtering: Off (1 Please help me

  151. creeperman5500 June 10, 2014 7:51 am  Reply

    it just crashes every time for me its very anoying

  152. theradtazz June 12, 2014 4:07 pm  Reply

    my download dose not start I hit ether save or open and it opens up lettering in my notepad what do I do for version 2.0.0

  153. dd5643 June 13, 2014 6:29 am  Reply

    when is morph 1.7?

  154. AwesomeFace123 June 17, 2014 1:08 am  Reply

    Um I don’t know if it’s downloading because I click Ichun util.jar and it just disappears and I don’t know if it is downloading

  155. Creeper12711 June 18, 2014 4:32 am  Reply

    I Am Having Trouble With Portal And Morphing Mods I Was Getting The Mod One Needed IChun 2.3.0 And The Other Needed IChun 2.4.0 So It Would Not Allow Me A Play With Both Or Play With One IT Crashed If I Deleted One PLEASE HELP

  156. pigman2023 June 21, 2014 2:38 am  Reply

    Ok so i was able to properly download ichun util but when i logged in to mine craft i was missing my head my arm and a leg and models from some other mods were messed up as well i have tried all versions in 1.6+ of the mod but the same thing happens every time.PLEASE HELP

  157. someoneyoudontknow June 21, 2014 3:41 pm  Reply

    i tried running gravity gun for 1.6.4 with ichun util for 1.6.4 but instead it says minimum versoin required is 3.0.0 which is for 1.7.2. i proceeded to remove all ichun mods, and it still requires 3.0.0 although i have no ichun mods but others, so i put it but the mods i have are for 1.6.4, so it asks for forge for 1.7.2 as the one im using is incompatible help!

    • MCSwaggins June 23, 2014 12:37 am  Reply

      Here: #1 get latest forge 1.7.2
      #2 Install iChun util 3.0.0
      #3 start up Minecraft. (you shouldn’t get the error)

      • MCSwaggins June 23, 2014 12:43 am  Reply

        Sorry, i messed up. do the exact same thing, exept open the ichun util with winrar, go to the mods file in ichun util, and drag the iChun util 3.0.0.jar into the Minecraft mods folder.

        (it has to be a .jar file not a .rar or .zip or it wont work)

      • Poppster9 July 10, 2014 7:28 am  Reply

        how do you install such ichun 3.3.0 or 3.0.0??

  158. MCSwaggins June 23, 2014 12:33 am  Reply

    New Update! :)

  159. Alin June 26, 2014 1:14 am  Reply

    ichun-util is a mod?

  160. The derp guy July 3, 2014 8:10 am  Reply

    Warning! If you see this –Minecraft Crash Report–
    SAD :(

  161. caseyconlin July 4, 2014 12:32 pm  Reply

    o no there’s something on ur face! *Punch* it was pain!!!

  162. caseyconlin July 4, 2014 12:34 pm  Reply

    help! i dont have a minecraft update pro :(

  163. dawid July 7, 2014 9:05 pm  Reply

    Proszę o dodanie wersi 3.0.0 na 1.6.x bo inne mody nie chcą działać bardzo proszę z góry dziękuje.

  164. MGF1998 July 9, 2014 9:28 pm  Reply

    Hey iChun,
    When I load your mod into Minecraft 1.7.10 (iChun Utility seems to cause the problem) and start a singleplayer world, I crash. Can you fix that soon? :D
    (btw it sometimes works on mp)
    Yours truly
    ~MGF

    • qwazwak July 19, 2014 5:38 am  Reply

      ASK AND HE DOESNT UPDATE YOU IDIOT!!!!!!!!!!!!!!!!!!!!!!!!!!
      its cuz ur on minecraft 1.7.10 and the util is 1.7.2

      • Unknown July 28, 2014 10:07 pm  Reply

        Shut up you stupid idiot. Period.

  165. Poppster9 July 10, 2014 7:25 am  Reply

    ermm how do you install the iChun Util 3.3.0? i hve been trying to figure it out but im not the best at this…

  166. Merrcats July 17, 2014 2:34 pm  Reply

    Hello, I downloaded the morph mod for 1.7.2. I also downloaded iChun util. When i opened minecraft it worked. everything went fine. When i checked the mods there was 22. (YES I HAVE A LOT OF MODS :D) and there was the morph mod. When i started playing the game i killed a mob. The animation started and every part flew on me…. But! i wasn’t morphed! I tried that with other mobs. Still. NOTHING. So i downloaded the older version for 1.7.2. Still. same. I don’t know what to do. please help

  167. Merrcats July 18, 2014 3:56 pm  Reply

    Oh dodn’t need anymore i fixed it… :)

  168. daws8394 August 6, 2014 9:17 pm  Reply

    Hey iChun,you have the wrong version wrote down for forge. 10.12.2.1128 doesnt exist. So your mods are kaput if you dont fix it.

    • Smithy August 8, 2014 12:05 pm  Reply

      It does this for me, too

  169. Chris Dove August 8, 2014 3:48 am  Reply

    Man, I hope the creator of Multi-MC reads this: It freezes upon adding IChunUtil to a Modpack made with that launcher.

    • Chris Dove August 8, 2014 3:49 am  Reply

      Never Mind, It only did it once.

  170. YouShotMeTwice August 10, 2014 7:12 pm  Reply

    This seems to be functioning just fine with the latest version of Forge at the time of writing.

  171. John Smith August 14, 2014 11:45 am  Reply

    This mod doesn’t work for me? it just crashes even if i’m installing it by itself :(

  172. Iamnotreallyhere August 17, 2014 2:10 am  Reply

    ichun util 4.0.0 seems to be malfunctioning as minecraft crashes if I include it in my mods folder.

    I don’t think this is a compatibility error as even on it’s own it crashes my minecraft.

    • Iamnotreallyhere August 17, 2014 7:25 am  Reply

      I was using 1.7.10 recommended version of Forge rather than the latest. Used the Latest version of the 1.7.10 and it worked without issues.

  173. mano August 19, 2014 3:19 am  Reply

    I Cant Download iChun Util Because repo/CreeperHost Is Down So please Fix it

  174. CrashedMods_X August 21, 2014 10:43 am  Reply

    didn’t work for me with any mods very :p about that

    but I have forge

  175. VIcTGM September 4, 2014 9:02 pm  Reply

    I can’t download iChunUtil. Any way, I am Vic, TheGoldMap

  176. jeremy verhoeven September 9, 2014 9:27 pm  Reply

    i can’t dowload ichunutil help

  177. Frost September 9, 2014 11:45 pm  Reply

    I installed some mods using Skydaz installers but I didn’t get iChunUtil 2.4.0 and 2.3.0 it doesn’t crash but when Minecraft starts up it says files are missing

  178. minfas_CZ September 10, 2014 12:29 am  Reply

    Not work when I install version for 1.6.X its says You must have newest version of iChunUtil when i install newest version it want 1.7!!!

  179. iChunUtil September 19, 2014 2:07 pm  Reply

    IM ICHUNUTIL AND IMMA FIX THA PROBLEM DONT WORRY :)

  180. iChunUtil September 19, 2014 2:09 pm  Reply

    If U Wanna Join A 1.5.2 Server Here Is tha Ip: MC.pvpmasters.nn.pe:25566

  181. billgus September 26, 2014 10:31 pm  Reply

    The 4.0.0 version (for the Portal-Gun mod) wants Forge 10.13.0.1186 but the released Forge is 10.13.0.1180.

  182. Very cross person September 27, 2014 6:03 pm  Reply

    You fucking screwed up my modds folder and now I can’t play on minecraft with modds ever again you piece of shit

  183. Petrik October 5, 2014 8:30 am  Reply

    So, it keeps giving me the save message that there’s a problem with forge. But ONLY when the Util is in the mods folder. if it isn’t forge works fine.
    How do I fix this?

  184. alexander October 7, 2014 1:40 am  Reply

    moi je peut parler french et aussi english

  185. jonh October 7, 2014 2:17 am  Reply

    sheet you

  186. fletcher October 12, 2014 9:47 pm  Reply

    for some reason there is not a 1.6.4 file please add one cause that’s the only forge i use and also YOU said that there WAS a 1.6.4 so why isnt it on there?

  187. fletcher October 12, 2014 9:48 pm  Reply

    also check out my youtube account at fletcher dedecker-haylett please

  188. Vivien Kiss October 21, 2014 11:58 pm  Reply

    iChun sorry to say but this mod of yours sucks. The morph mod looked super awesome, but when i downloaded it, then downloaded this iChun util thing too, for 1.7.2 (because in the new 1.8 lan mode doesn’t work. whatever) so, i have forge for 1.7.2, everything splendid, then minecraft crashes and your util crap asks for a newer forge version. HOW THE FUCK?i have the newest for 1.7.2. i can’t update it further.

  189. nikolinum October 29, 2014 12:38 am  Reply

    I can´t download IChun and the morph mod :( i want this mods these are great

Leave a comment

Your email address will not be published. Required fields are marked *