Hat Stand


Currently for Minecraft 1.7.10

This is an addon to the Hats Mod. You require that to be installed before this can work.

Why an addon?
– Hats is compatible on servers without it. This on the other hand, is not.

This mod adds a single block item, a Hat Stand:

Servers require this mod to be installed before the client can use it. Ignoring this advice may lead to crashes.


What else do I need for this mod? What version should I get? Help? Answered on the FAQ.

Remember, this mod requires Hats!


Minecraft 1.5.X


Minecraft 1.4.7


  1. bennet April 16, 2013 9:24 am  Reply


    • Graham July 13, 2013 4:17 am  Reply

      I Know Right? IChun Is Like My Hero!!

      • direwolf20 September 15, 2015 9:22 pm  Reply

        But he trolls me so much!

  2. legobun_MC April 18, 2013 1:53 am  Reply

    plz update this addon to its 1.1.0 cuz you cant use it forge says that version 1.1.0 is required soo plz update it

    • Aiden May 15, 2013 6:06 am  Reply

      Um… I think it means for you to update the mod here.

    • gfyjhyuhgytuhyghgcuvnit IMMA GOUY September 13, 2013 8:33 pm  Reply

      really u use the OLDEST version of minecraft (past beta) YYYYYYYYYYYYYYYYYYY update u n00000000000000000000000000000000000000000000000000000000000000000000000b

  3. goldcat99 April 22, 2013 7:38 am  Reply

    aww no 1.4.7?

  4. KillKreditBunny April 27, 2013 6:56 pm  Reply

    It’s a really awesome mod, but the id conflicts with one of my other mods and the config is empty by default… How do I change it (I have the latest 1.4.7 version)

    • xCouzchat7 April 28, 2013 1:50 am  Reply

      Yes, I would like to know this aswell.

      • iChun April 28, 2013 3:08 am  Reply

        Found the issue. Will update this + hats (hats needs a nerf) tomorrow.

        • iEnderMan06Real! March 15, 2015 3:28 pm  Reply

          iChun, i’m currently making a Modpack, and it contains a lot of your mods, i was just wondering if you could give permission to – Thanks!

          • iEnderMan06Real! March 15, 2015 3:30 pm 

            lol, permission to do it* – Thanks!

  5. Brandon April 30, 2013 8:26 am  Reply

    so just drop it in mods folder ? i have a mac so it unzips it and stuff

    • N00byEdge May 8, 2013 5:17 pm  Reply

      No. Just drop it in there without unzipping / extracting, if you can’t manage, use a pc instead. :)

      • Mortvana May 20, 2013 8:14 am  Reply

        …Or a UNIX based OS

        • rilwal May 27, 2013 2:37 pm  Reply

          Have to point out here, OSX IS UNIX based, along with various BSDs. Linux (which I assume you were thinking of) is UINX like.

      • Extracting??? April 26, 2015 3:30 pm  Reply

        For me it installed a .jar file and it worked fine. I’m not sure if this is true, but I think the newer versions use .jar, but I’m not sure.

  6. saki2fifty July 13, 2013 5:01 am  Reply

    Something wrong with the download? Looks like it might be a bad link?

  7. donquiche August 19, 2013 4:45 am  Reply

    Just a question :

    what is the mod for the rug pig on the picture ?

    • deFENCE_ September 8, 2013 2:21 pm  Reply

      Hat Stand by iChun. -.-

  8. Sterling September 5, 2013 7:41 am  Reply

    How does one install for the server? Is it even possible?

  9. comaskid December 23, 2013 4:39 am  Reply

    my friend found a way to make it so you collect the hats from animals once you kill them if they have a hat on but I don’t know how and they wont say…can you tell me if this Is possible and how?

    • A_Hat_User January 23, 2014 12:55 pm  Reply

      Easy, press ‘h’ in game

  10. Awsomeness2435 April 27, 2014 1:19 pm  Reply

    IChun Yor Doing Great Keep up the good work

  11. Anonymous May 24, 2014 3:52 pm  Reply

    iChun You Are THA BEST!

  12. nathan September 2, 2014 2:47 am  Reply

    1073 Crisifield Dr
    wont work for me check out my youtube channel at nathan prueitt

  13. Dalty5352 October 13, 2014 12:13 am  Reply

    This is so cool! but only 1 problem… i click ‘H’ and it don’t bring me to the hats ;~;

  14. Dalty5352 October 13, 2014 12:14 am  Reply

    reply me if u know what to do

  15. DangerMan_500 November 1, 2014 5:56 am  Reply

    Well My 1.7.2 server is not working so I prefer 1.8 when forge made that

    • Zsashas December 6, 2014 1:29 am  Reply

      There’s probably not going to be a 1.8 version, like with nearly every other mod. Just because Forge works with 1.8 doesn’t mean that anything else does.
      If this ISN’T you asking for a 1.8 version, then disregard this.

Leave a comment

Your email address will not be published. Required fields are marked *